Posts Tagged with ubuntu error

Displaying 1-3 of 3 results.
Resolved: Ubuntu Linux remove directory from root var/www directory problem
posted by admin on February 7, 2017
I try to remove folder but terminal gave error
Command and error

rm -rf /var/www/website.dev
rm: cannot remove '/var/www/website.dev': Permission denied

I try to did it before this command and the same situation

sudo chmod -R 777 /var/www/website.dev

I try to make my user superuser but still without result

sudo adduser <username> www-data
sudo chown -R www-data:www-data /var/www
sudo chmod -R g+rwX /var/www
Read more
Resolved: Composer Ubuntu installation and errors
posted by admin on January 18, 2017
I am trying to install composer by that way and get some errors.
Instalation
Step 1: Ensure the Curl dependency is installed.

sudo apt-get -y install curl


Step 2: Download the Composer installer and pass it to php.

sudo curl -sS https://getcomposer.org/installer | php

My error in this step:

The program 'php' can be found in the following packages:
* php7.0-cli
* hhvm
Try: sudo apt install <selected package>
curl: (23) Failed writing body (0 != 16133)
Read more
Resolved: Skype Ubuntu This software comes from a 3-rd party and may contain non-free components error
posted by admin on January 18, 2017
I am trying to install skype to ubuntu and all methods which I use didn't resolve this error

This software comes from a 3-rd party and may contain non-free components error


In command line I have got error like this

You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies:
google-chrome-stable : Depends: libpango1.0-0 (>= 1.14.0) but it is not going to be installed
Depends: libappindicator1 but it is not going to be installed
ubuntu-restricted-extras : Depends: ubuntu-restricted-addons but it is not going to be installed
Recommends: ttf-mscorefonts-installer but it is not going to be installed
Recommends: unrar but it is not going to be installed
Recommends: libavcodec-extra
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).



I try to install gdebi installer, and have got error too

sudo apt install gdebi

Error:

Reading package lists... Done
Building dependency tree
Reading state information... Done
You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies:
gdebi : Depends: gdebi-core (= 0.9.5.7ubuntu1) but it is not going to be installed
Depends: gksu but it is not going to be installed
Depends: gnome-icon-theme but it is not going to be installed
Recommends: libgtk2-perl but it is not going to be installed
google-chrome-stable : Depends: libpango1.0-0 (>= 1.14.0) but it is not going to be installed
Depends: libappindicator1 but it is not going to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).

Read more